Warning: Declaration of All_in_One_SEO_Pack::get_current_options($opts = Array, $location = NULL, $defaults = NULL) should be compatible with All_in_One_SEO_Pack_Module::get_current_options($opts = Array, $location = NULL, $defaults = NULL, $post = NULL) in D:\WEB\blogs\zekeriyamulbay\blog\wp-content\plugins\all-in-one-seo-pack\aioseop_class.php on line 12
Mantıksal İşlevler (Excel) | Kalabalığın Gücü
Skip to content

11 Ocak 2012

Mantıksal İşlevler (Excel)

Üzerinde çalıştığımız hücrelerin birinin veya bir kaçının istediğimiz özelliğe sahip olup olmamasına bağlı olarak farklı işlemler gerçekleştirebilen işlevlerdir. Bu yazıda temel mantıksal işlevlerden olan “Eğer, ve, yada, değil” işlevleri gösterilecektir.

Daha önceki örneklerde kullandığım ERASMUS not tablosunu burada da kullanacağım. İşlenmemiş hali aşağıdaki gibidir:

Şimdi işlevlerimizi örnekler yardımıyla anlatalım:

“=EĞER(koşul; koşul sağlandığında yapılacak; koşul sağlanmadığında yapılacak)”: Bu işlevin ilk parametresi bir koşu içermektedir. Bu koşul sağlanırsa ikinci parametredeki sağlanmazsa üçüncü parametredeki işlem yapılacaktır. Tablomuzun sağında yeni bir sütun oluşturalım ve bunu “Geçme Durumu” şeklinde adlandıralım. Bu sütunda yer alan hücreler sol taraflarında bulunan geçme notlarının durumuna göre “Geçti” veya “Kaldı” olarak değerleneceklerdir. Geçme sınırımızı 60 olarak belirleyelim ve F3 hücresine “=EĞER(E3>=60; “Geçti”; “Kaldı”)” yazalım. E3’deki değer 60′ dan küçük olduğu için F3 hücresinde “Kaldı” görünecektir. Şimdi bu hücresin sağ altındaki siyah kareye iki defa tıklayarak bütün satırlar için aynı işlemi yapmasını sağlayalım. Bu çalışma sonucunda tablonun alacağı durum aşağıdaki gibidir:

“=VE(koşul1; koşul2;…;koşul30)”: Bu işlev ile birden fazla koşul aynı anda denetlenebilir. Eğer parametrelerde yer alan koşulların tamamı sağlanıyorsa formül DOĞRU değerini döndürür. Aksi durumda YANLIŞ değerini döndürecektir. Şimdi hem Mimarlık okuyan lisans öğrencilerinden notu 60 ve üzeri olanları geçirelim. Bunun için F3 hücresine yazacağımız formül “=VE(C3=”Mimarlık”; D3=”Lisans”; E3>=60)” olmalıdır. Formül bütün satırlara uygulandığında ise aşağıdaki tablo oluşacaktır:

Görüleceği üzere Mimarlık Bölümü’ nde Lisans okuyan üç öğrenciden notları yeterli olan Andaç ve Aygün sınavı geçebilmişlerdir.

“=YADA(koşul1; koşul2;…;koşul30)”: Bu işlevin “VE”den farkı, parametrelerini oluşturan koşullardan, sadece bir tanesinin sağlanması durumunda “DOĞRU” döndürecek olmasıdır. Yukarıdaki örnekteki formülde yer alan “VE” işlevini “YADA” ile değiştirdiğimizde aşağıdaki tabloyu elde etmiş olacağız:

Bu değerlendirmede Mimarlık Bölümü, Lisans veya not durumlarından herhangi birisinin sağlanması durumunda sınavdan geçilecektir. Bu değerlendirmeye göre tek kalan kişi notu 35 olan Fizik Yüksek Lisans öğrencisidir. Görüleceği üzere hiçbir şartı sağlamamıştır.

“=DEĞİL(koşul)”: Burada koşul sağlanıyorsa YANLIŞ, sağlanmıyorsa DOĞRU değeri döner.

Yukarıda anlatılan işlevlerin iç içe kullanıldığı durumlarda söz konusu olabilir. Basit olarak geçme durumunu DOĞRU-YANLIŞ şeklinde değil de GEÇTİ-KALDI şeklinde bildirmek isteyebiliriz. Burada kullanmamız gereken formül “=EĞER(VE(C3=”Mimarlık”; D3=”Lisans”; E3>=60); “Geçti”; “Kaldı”)” şeklindedir. Basit bir EĞER formülünün ilk parametresinde VE işlevi kullanılmış ve bu iç işlevin dönüşüne göre Geçti-Kaldı değerlerine ulaşılmıştır.

Share your thoughts, post a comment.

You must be logged in to post a comment.