Warning: Declaration of All_in_One_SEO_Pack::get_current_options($opts = Array, $location = NULL, $defaults = NULL) should be compatible with All_in_One_SEO_Pack_Module::get_current_options($opts = Array, $location = NULL, $defaults = NULL, $post = NULL) in D:\WEB\blogs\zekeriyamulbay\blog\wp-content\plugins\all-in-one-seo-pack\aioseop_class.php on line 12
Koşullu Fonksiyonlar (Excel) | Kalabalığın Gücü
Skip to content

25 Aralık 2011

Koşullu Fonksiyonlar (Excel)

Belirli bir koşula bağlı gerçekleşen işlemlere göz atalım. Bu inceleme sırasında, daha önceki yazılarımda kullandığım basit bir örnekten yararlanacağım. Tekrar hatırlatmak adına verilerimiz bir meyve & sebze halinden alınmıştır. Burada günlük gelen veriler herhangi bir sıralamaya tabi tutulmadan yazılmaktadır.

Örneğimizden yola çıkarak koşullu fonksiyonlara bakalım:

“=ETOPLA()”: Bu fonksiyon belirli koşula uyan değerlerin toplamını alır. “=ETOPLA(B4:B14;”Karpuz”; D4:D14)” formülünde B4:B14 aralığında “Karpuz” değerine sahip olan satırların D4:D14 aralığındaki karşılıkları toplanır ve sonuç 28 olarak bulunur.

“=ÇOKETOPLA()”: Bir önceki fonksiyondan farklı, toplanacak değerlerin belirlenmesinde, birden fazla koşul içermesidir. “ETOPLA” fonksiyonunda toplanacak aralık en son belirlenirken bu formülde ilk sırada belirlenmektedir. “=ÇOKETOPLA(D4:D14; B4:B14; “Elma”; C4:C14; “Amasya”)” örneğinde Amasya’dan gelen elma miktarına ulaşılacaktır. Görüleceği üzere ilk olarak toplanması gereken aralık (D4:D14) sonrasında ise şartlar verilmiştir. Eğer ikiden fazla şartımız varsa bu yazım şekli ile istediğimiz kadar şart ekleyebiliriz.

“=EĞERSAY()”: İstenilen koşula uyan değerlerin sayısının döndürmektedir. “=EĞERSAY(D4:D14; “>20″)” fonksiyonunda miktarı 20 tondan fazla olan girişlerin sayısına ulaşılacaktır (2 adet). Aynı şekilde “=EĞERSAY(C4:C14; “Isparta”)” fonksiyonu ile Isparta ilinde kaç adet giriş yapıldığı bilgisine ulaşılabilir.

“=ÇOKEĞERSAY()”: Birden fazla koşulu aynı anda sağlayan girdilerin sayısını döner. “=ÇOKEĞERSAY(B4:B14; “Karpuz”; C4:C14; “Mersin”)” örneğinde Mersin’den kaç adet karpuz yüklü araç girişi yapıldığı verisine ulaşılabilir. Ayrıca “=ÇOKEĞERSAY(C4:C14; “Antalya”; D4:D14; “>10″)” örneği ile Antalya’dan giriş yapmış ve yükü 10 tondan fazla olan araçların sayısına ulaşılabilecektir.

“=EĞERORTALAMA()”: Şartı sağlayan değerlerin ortalamasını döndürmektedir. “=EĞERORTALAMA(C4:C14; “Adana”; D4:D14)” örneği ile Adana’dan gelen araçların ortalama ne kadar yük getirdiği bilgisine ulaşılmaktadır.

“=ÇOKEĞERORTALAMA()”: Bir önceki fonksiyonun birden fazla şarta sahip versiyonudur. Bu formül yazılırken de, diğer “ÇOK” ile başlayan formüllerde olduğu gibi, ilk olarak işlem yapılacak (burada ortalaması alınacak) veri aralığı girilir. Sonrasında ise istenildiği kadar (örneğimizde sadece iki adet) şart belirtilir. “=ÇOKEĞERORTALAMA(D4:D14; B4:B14; “Elma”; D4:D14; “<10″)” örneğinde 10 tandan az elma ile giriş yapan araçların ortalama ne kadar elma getirdikleri bilgisine ulaşılabilmektedir.

Share your thoughts, post a comment.

You must be logged in to post a comment.