Warning: Declaration of All_in_One_SEO_Pack::get_current_options($opts = Array, $location = NULL, $defaults = NULL) should be compatible with All_in_One_SEO_Pack_Module::get_current_options($opts = Array, $location = NULL, $defaults = NULL, $post = NULL) in D:\WEB\blogs\zekeriyamulbay\blog\wp-content\plugins\all-in-one-seo-pack\aioseop_class.php on line 12
Arama Fonksiyonları (Excel) | Kalabalığın Gücü
Skip to content

25 Aralık 2011

Arama Fonksiyonları (Excel)

Bu yazımda büyük bir tabloda çalışırken veya bir tablodaki veriler ile başka tablodaki verileri çaprazlamada sıklıkla kullanılan fonksiyonları inceleyeceğiz. Her zamanki gibi bir örnek ile başlayalım:

Örneğimiz biraz karmaşık :) Londra Borsası’ nda yer alan firmalar çeşitli nitelikleri ile listede yer almakta. Tablo gözünüzü korkutmasın, anlatım için oldukça küçük bir dilimini kullanacağım.

“=DÜŞEYARA()”: Bu fonksiyonu düşey listelerde arama yapmak için kullanılmaktadır. Bu fonksiyonu daha iyi anlamak adına “=DÜŞEYARA(“ABCAM”; B3:F23; 3; YANLIŞ)” örneğini inceleyelim. Bu örnekte kullanacağımız kaynak tablo B2:F23 aralığındadır. Kaynak tablo seçiminde dikkat edilmesi gereken en önemli hususlardan ilki; aranacak değerin olduğu sütunun bu tablonun en sol sütununu oluşturması ve elde edilmek istenilen değerin yer aldığı sütunun bu kaynak tablo içerisinde yer alması gerekliliğidir. Konumuza dönersek seçilen kaynak tablo 5 sütundan oluşmaktadır. Arama yapmak istediğimi kelime “ABCAM” dır ve bu tablonun ilk sütununda yer almaktadır. Fonksiyonun üçüncü parametresi olan “3” değeri dönüş almak istediğimiz değerin üçüncü sütunda yer aldığını (Bu kaynak tabloda “Sector” sütunu) belirtmektedir. Son parametre için “DOĞRU” değerini kullandığımızda birebir eşleşen aramalarda sonucu döndürürken “YANLIŞ” parametresi girildiğinde aramaya en yakın sonuç döndürülmektedir. Kısaca bu formül için elde edilecek geri dönüş “Travel & Leisure”dir.

“=YATAYARA()”: Bir önceki fonksiyon ile aynı parametreleri kullanmaktadır. Farkı ise, adından da anlaşılacağı üzere, yatay listelerde arama yapmasıdır.

“=ARA()”: DÜŞEYARA veya YATAYARA fonksiyonlarının kullanılamadığı (genellikle aranacak kelimenin ilk sütunda olmadığı) durumlarda kullanılmaktadır. “=ARA(5555; C4:C23; B4:B23)” örneğinde 5555 değeri C4:C23 aralığında aranacak ve B4:B23 sütun kesitindeki karşılığı sonuç olarak dönülecektir. Görüleceği üzere burada aranacak değerin ilk sütunda olması gibi bir zorunluluk bulunmamaktadır.

“=ELEMAN()”: Bir dizide talep edilen indis numarasına karşılık gelen girdiyi döndürmek için kullanılır. “=ELEMAN(2; C4; C5; C6; C7; C8)” örneğinin döndüreceği değer C5 hücresindeki “8775” değeri olacaktır. Bu formülün kullanım zorluğu dizideki değerlerin toplu seçimine (C4:C8 gibi) izin vermemesidir. Dizideki her bir değer tek tek seçilmelidir.

“=İNDİS()”: Bu fonksiyonda diziler matris olarak kabul edilmektedir. Sadece tek satır veya tek sütundan oluşmayıp, iki boyutu olan, tablolarda hem yatay hem de dikey konuma göre istenilen hücre değeri döndürülebilir. “=İNDİS(A4:F23; 1; 5)” fonksiyonu kaynak tablonun (A4:F23) 1. satırı ile 5. sütununun kesişim hücresi olan “Software” değeri ile dönecektir.

“=KAÇINCI()”: Tek boyutlu kaynak dizisinde belirlenen değerin kaçıncı sırada olduğunu verir. “=KAÇINCI(“600 Group”; B4:B23; 0)” örneğinde B sütununda yer alan “600 Group” değeri aranmıştır. Formül 11 değerini döndürecektir. Formülün son parametresi olarak “0” değerini görüyoruz. Bu parametre ile aranan değere tam olarak uyan hücrenin sırası verilecektir. Bu parametre “1” olduğunda aranan değerden küçük veya eşit olan hücrenin, “-1″ ise aranan değerden büyük veya bu değere eşit olan hücrelerin sırasın getirecektir.

“=ADRES()”: Bu formül satır ve sütun numaralarına göre adres bilgisini döndürmektedir. “=ADRES(4;5;1;2;)” örneğinde 4. satır ve 5. sütunun kesiştiği hücrenin adresi döndürülür. Üçüncü parametre olan “1” ile adres değerlerinin her ikisine (hem satır hem de sütun) $ işareti koyarak sabit kılar. Diğer değerlerine bakacak olursak; 2: sabit satır göreceli sütun, 3: göreceli satır sabit sütun, 4: hem satır hem de sütun göreceli. Sn parametrenin yazılı olmadığını fark etmişsinizdir. Bu parametreye girilecek değer sayfa ismidir. Bir başka değişle; eğer istediğimiz adres başka bir Excel sayfasında yer alıyorsa bu kısım doldurulmalıdır. Bu örnek sonucunda elde edeceğimiz değer “$E$4″ olacaktır.

“=DOLAYLI()”: Bir önceki formül il elde edilmiş olan adres bilgisine dayanarak veriye ulaşır. İki adet parametresi vardır. İlk parametresinde ulaşılmak istenilen verinin adresi kullanılır. İkinci parametresine ise Doğru(A1 Stili) veya Yanlış (R1C1 Stili) değerleri girilir. “=DOLAYLI(“$E$4″; DOĞRU)” formülünün cevabı “Software” olacaktır.

“=SATIR() ve =SÜTUN()”: Bu iki formülün de tek parametresi bulunmaktadır. Parantez içerisine aldıkları adres bilgisinin sütun numarasını veya satır numarasını döndürmektedir.

“=SATIRSAY() ve =SÜTUNSAY()”: Parantez içerisine bir dizi veya tablo adresi girildiğinde bu girdinin kaç satır veya kaç sütundan oluştuğunu veriyor. “=SATIRSAY(A4:F23)” örneğinin cevabı “20” olacaktır.

Share your thoughts, post a comment.

You must be logged in to post a comment.